Archivos diarios: septiembre 3, 2012

Reparar el índice dañado de un archivo AVI en Linux Ubuntu

El problema

El día de hoy tenía que consultar un video en formato AVI que parecía tener problemas.  El Movie Player lo abría sin mensajes de error sin embargo se demoraba varios minutos en presentarlo, VLC en cambio mostraba un mensaje de error acerca del índice del video dañado y era posible repararlo pero aparentemente de manera temporal porque sucedía igual cada vez que abría el archivo.

A continuación se muestra el procedimiento utilizado para corregír el índice defectuoso del archivo de video utilizando una herramienta de linea de comando.

La solución

Instalar MEncoder si no se cuenta con él aún.

$ sudo aptitude install mencoder

Invocar el siguiente comando en el que original_video.avi es el archivo original del video y fixed_video.avi

es el archivo resultante después de la corrección del índice.

$ mencoder -idx original_video.avi -ovc copy -oac copy -o fixed_video.avi

Fuente

Convierte los manuales (man) en PDF

Muchos de los usuarios de GNU/Linux cuando queremos saber como funciona algún programa, revisar sus opciones, o simplemente leer su documentación, hacemos uso de MAN.

MAN es el paginador o visor de manuales del Sistema, y por lo general cada programa que instalamos, incluye su manual electrónico el cual podemos ver con esta aplicación. Su uso es muy sencillo, solo tenemos que poner en el terminal el comando:

$ man [aplicación]

Sustituyendo [aplicación] por el nombre del programa. Por ejemplo, si queremos ver la documentación o manual del propio MAN, ponemos:

$ man man

Y nos saldrá algo como esto:

MAN tiene muchísimas opciones para explorar los manuales y sus secciones, pero este post no es para explicar su funcionamiento. Hasta ahí todo muy bonito.

Pero podemos leer estos manuales de forma más cómoda simplemente llevándolos a formato PDF. ¿Cómo lo hacemos? Pues muy sencillo:

man -t man | ps2pdf - > man.pdf

Con esto debería ser suficiente. No obstante, para ciertas versión de Acrobat Reader, es necesario reemplazar ps2pdf por estos:

ps2pdf12 – Convertir PostScript a PDF de 1,2 (Acrobat 3 y posterior compatible) usando ghostscript
ps2pdf13 – Convertir PostScript a PDF 1.3 (Acrobat 4 y posterior compatible) usando ghostscript
ps2pdf14 – Convertir PostScript a PDF 1.4 (Acrobat 5 y posterior compatible) usando ghostscript

Listo. Ya podemos llevar nuestros manuales a donde queramos

Fuente

Xnoise media player 0.2.9 instalarlo via PPA

Un reproductor de audio y vídeo para Gnome muy liviano que soporta todos los formatos de audio y video que gstreamer puede manejar.

Ha sido liberada la versión 0.2.9 con esta lista de cambios:

* Redesign GUI for Settings-Dialog and for Add-Media-Dialog
* use strip function on artist and album imports
* Extend media import API
* Extend item handler API
* Add fix for window hiding/howing (Tal)
* Update portugse translation (Sergio Marques)
* Activate standard item handlers for dynamic playlists, too
* Context menus for dynamic playlists
* Add query interface for dynamic playlists
* Fix keyboard opened menus for tracklist and musicbrowser
* Use nautilus feature (if available) for file indication
* Add FAQ entry to help menu
* Magnatune: add support for ‘speechless’ streaming with user login
* Magnatune: album downloads for registered users
* Magnatune: add online change monitoring
* Magnatune: use album images in Magnatune plugin
* Magnatune: use genre in search/filtering
* Magnatune: change store location of db
* Update packaging data
* Replace hard coded keycodes with the (now available) Gdk.Key.* constants
* Recommend tumbler thumbnailing in packaging
* Update debian package creation script (Tal)
* Code cleanups
* Various bug fixes

Lo podemos instalar o actualizar en Ubuntu 11.10 en adelante con este PPA:

sudo add-apt-repository ppa:shkn/xnoise
sudo apt-get update
sudo apt-get install xnoise

Fuente

Translate »