PSeInt – Pseudocodigo para no programadores

Son muchas las carreras no informaticas en las que en algun momento enseñan logica de programacion utilizando diagramas de flujo y pseudocodigo. Lo dificil es enseñar a probar esos codigos en algun lenguaje de programacion porque habria que enseñar lo basico de ese lenguaje. Pero PSeInt nos sirve para evitar tener que aprender un lenguaje y quedarnos solo con los diagramas y escribir un pseudocodigo que realmente podamos probar.

La idea basica es escribir codigo en español y lograr ver un resultado ejecutable.

Ej:  El siguiente codigo calcula el promedio de una lista de datos.

// Calcula el promedio de una lista de N datos
Proceso Promedio
          Escribir “Ingrese la cantidad de datos:”;
          Leer n;
          acum<-0
          Para i<-1 Hasta n Hacer
                  Escribir “Ingrese el dato “,i,”:”;
                  Leer dato;
                  acum<-acum+dato;
          FinPara
          prom<-acum/n;
          Escribir “El promedio es: “,prom;
FinProceso

Como veran los comandos que se usan son “Leer”, “Para”, “Escribir”, y tambien existen otros como el clasico “Si-Sino-Entonces”. Codigo realmente facil de entender. Y seguro algunos programadores van a decir: ‘deberian enseñar directamente usando un lenguaje real’, pero estoy seguro que entonces nunca se han topado con medicos, contadores, etc que no saben nada de nada de pcs. Esto SI ayuda mucho.

La ejecucion del programa se muestra en una consola que el mismo programa abre. Algo asi:

El programa tambien sirve para enseñar mediante diagramas de flujo. Es decir que se pueden crear y editar bloques y asi crear el pseudocodigo y ejecutar el programa.

El programa cuenta con mucha documentacion integrada y codigos de errores claros y entendibles por cualquiera. Todo en español por supuesto. En la web tambien hay mas documentacion, codigos de ejemplos y videos para entender el programa.

Como instalar pseint?

En la pagina oficina estan las opciones de descarga para windows, linux y mac os. Como nosotros usamos linux lo que vamos a hacer es elegir la version (32 o 64 bits), descomprimir el paquete y luego le dan doble click al archivo llamado wxPSeInt.

Esto no lo instala sino que lo ejecuta directamente.

Espero que les sirva, en especial a los profesores de algunas carreras universitarias

Web oficial y descarga: pseint.sourceforge.net

Fuente