Solucionando problemas con las firmas GPG de los paquetes en GNU/Linux Ubuntu y Mint

Introducción

Después de una acción aún no determinada, posiblemente agregar un nuevo repositorio de paquetes al sistema operativo, empecé a obtener errores de firmas GPG como los siguientes durante la actualización de los índices de los paquetes en los repositorios con Aptitude.

W: GPG error: http://archive.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG B9316A7BC7917B12 Launchpad chrislea
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG B6C6326781C0BE11 Launchpad All you need for Ruby/Rails development on Ubuntu
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG C2518248EEA14886 Launchpad VLC
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG C2518248EEA14886 Launchpad VLC

La solución

Para solucionar esta situación se siguieron los pasos mostrados a continuación.

Limpiar los paquetes almacenados en el sistema de archivos local descargados durante procedimientos anteriores.

$ sudo apt-get clean

Renombrar (mover o remover) las listas de índices de paquetes actualmente manejadas por el sistema operativo.

$ sudo mv /var/lib/apt/lists /var/lib/apt/lists.old

Solicitar nuevamente las listas de índices de los paquetes contenidos en los repositorios actualmente registrados en el sistema operativo

$ sudo apt-get update

Fuente