Como instalar Firefox 3.7 con soporte para WebM

WebM es el nuevo proyecto de código abierto sponsoreado por Google, Mozilla, Opera y muchas otras grandes firmas, que utiliza el códec de video VP8 liberado por Google así como el códec de audio OGG Vorbis para reproducir videos HTML5. La ventaja principal de este nuevo sistema es que ya no vas a tener que depender de Flash para poder ver videos en YouTube y otros sitios por el estilo; consumirá, además, muchos menos recursos de tu sistema y estarás utilizando códecs libres, por lo que no vas a tener que preocuparte por posibles problemas de licencias.

Firefox 3.7 (que pronto se convertirá en 4.0) incorporó soporte para WebM recientemente. El Ubuntu Mozilla Daily PPA incorporó esta nueva versión para que finalmente puedas instalar Firefox con soporte para WebM en tu Ubuntu, aunque sólo está disponible para 32 bit por el momento.

Además de incorporar soporte para WebM, el Firefox 3.7 (4.0) disponible en el Mozilla Daily PPA también viene con un nuevo administrador de extensiones:

Por favor, no olvides que esta es todavía una versión inestable y que probablemente tenga varios bugs. Además, tené en cuenta que este PPA va a actualizar tu “viejo” Firefox 3.6 al nuevo 3.7. En caso de que no quieras que esto suceda sólo tenés que remover el PPA.

Instalar Firefox 3.7 (alias 4.0) en Ubuntu:

sudo add-apt-repository ppa:ubuntu-mozilla-daily/ppa

sudo apt-get update && sudo apt-get install firefox-3.7

Firefox precisa libvpx por alguna razón. Esto, lamentablemente, no está disponible en el Ubuntu Mozilla Daily PPA, pero podés instalarlo desde el Chromium Daily PPA:

sudo add-apt-repository ppa:chromium-daily/ppa

sudo apt-get update && sudo apt-get install libvpx0

Listo. Ya podés usar Firefox con soporte para WebM.

Para usar WebM en YouTube, habilitá el uso de HTML5 y probá algunos videos WebM, como este.

Fuente