Archivos Mensuales: junio 2010

KDE SC 4.5RC1 disponible para openSUSE, Kubuntu y ArchLinux

Hace un par de días apareció la primera RC de KDE SC 4.5 y ya tenemos sus versiones para probarlas en algunas de las distribuciones.
Concretamente en:

OpenSuSE

Debes añadir el repositorio KDE4:/UNSTABLE:/Desktop/openSUSE_11.x de la página de repositorios de OpenSuSE
Vía: Tittiatcoke’s Blog

KUbuntu

Para actualizar se puede utilizar el Software Repository Guide y añadir el siguiente repositorio:

ppa:kubuntu-ppa/beta/

Vía: KUbuntu

Arch Linux

Finalmente os invito a visitar la página de Iyanmv.com para ver el proceso completo para esta distribución.

Fuente

Universal USB Installer: crea versiones portables y persistentes de cualquier distribución de Linux

Universal USB Installer es una herramienta que permite crear versiones portables y persistentes de casi cualquier distribución de Linux, para volcarlas a pendrives. De manera extremadamente simple, tendremos en un pendrive un sistema Linux al gusto, que además conservará nuestras preferencias entre cada vez que lo utilicemos.

Tan sólo necesitamos ejecutar la aplicación en el mismo directorio en el que tengamos la ISO de nuestra distribución favorita, indicarle la ruta al pendrive que queramos usar y darle a “Instalar”. Como únicas opciones se ofrece activar la persistencia (si es posible para la distribución seleccionada) y el formateo previo del pendrive, recomendado para una instalación limpia.

La propia herramienta te facilita la descarga de las ISOs más recientes de decenas de distribuciones. Universal USB Installer funciona en Windows y ocupa menos de megabyte, aunque también existe otra aplicación similar para Linux, llamada “Linux Live USB Creator”, con las mismas características.

Por ahora no soporta la posibilidad de instalar varias distros de Linux en un único pendrive, pero ya tienen previsto incluir esta opción en un futuro. Además, sólo por la comodidad de tener a mano los enlaces de descarga de decenas de ISO de las distribuciones más conocidas ya merece la pena.

Sitio oficial | Pendrive Linux, versión para Linux
Descarga | Descarga Universal USB Installer (Windows)

Fuente

Solucionar dependencias inclumplidas

Para solucionarlo utilizamo cualquiera de  los siguientes comando:

sudo apt-get -f install

o

aptitude safe-upgrade

o si conoces el que necesita de las dependencias con un

aptitude build-dep ‘nombre_app’

en ultimo caso no muy recomendado un :

aptitude full-upgrade

o
sudo dpkg –configure -a

Fuente

Transmission 2.01

El cliente bittorrent que viene por defecto en Ubuntu ha sido actualizado a su versión 2.0.1 con esta lista de cambios:

All Platforms

  • Better tracker announce management when completed torrents are moved from the incomplete directory
  • Speed up moving local data from one disk to another
  • Better parsing of nonstandard magnet links

Mac

  • If the seed ratio is already met when download completes, still show the Growl notification and download-complete sound
  • Fix the Help buttons in the preferences window

GTK+

  • Faster torrent file parsing
  • Fix the magnet link options dialog does not respect setting
  • Add an error popup if “Add URL” fails

Qt

  • Fix crash after getting magnet torrent metadata
  • Fix torrent ratio goals
  • Fix “add torrent” dialog bug on KDE desktops that popped up previous torrents
  • Fix 2.00 bug that prevented multiple instances from being run
  • Fix remote mode bug that kept the torrent list from being shown
  • Support encryption settings in the preferences dialog
  • Use flagStr in the status field of the peer list
  • Request a full refresh when changing the session source
  • Fix the torrent list jumping to the top when a torrent is removed

Web Client

  • Fix display bug caused by removal of a torrent hidden by the current filter

Lo podemos actualizar en Lucid agregando su repositorio en Launchpad:

sudo add-apt-repository ppa:transmissionbt/ppa

sudo aptitude update

sudo aptitude upgrade

Instalar y Desinstalar Paquetes deb con dpkg

En algunas ocasiones no se usa aptitude o apt para instalar un paquete o programa en Debian o Ubuntu, sino que se descarga el paquete *.deb y lo instalamos usando dpkg. En esta oportunidad quisiera compartir algunas opciones básicas de este comando.

Instalando usando dpkg -i

La sintaxis para instalar un paquete deb es la siguiente:

dpkg -i paquete.deb

El -i es usado para instalar.

Para verificar que un paquete ha sido instalado, usamos el siguiente comando:

dpkg -l | grep 'openoffice'

ii  openoffice.org-base-core                   1:3.0.1-9ubuntu3.3                            full-featured office productivity suite — s

Donde ii significa que esta instalado en el sistema.

Desinstalar usando dpkg -r

Para remover o desinstalar un paquete se usa la siguiente sintaxis:

dpkg -r paquete.deb

Y para purgar el paquete, es decir que no quede nada de este, se usa lo siguiente:

dpkg -P paquete.deb

Fuente

Liberado Thunderbird 3.1, instalación mediante Ubuntuzilla

La gente de Mozilla ha liberado una nueva versión de su cliente e-mail; se trata de la versión 3.1 que trae importantes mejoras, siendo las principales: hacer uso de la plataforma Gecko 1.9.2, para mejorar el rendimiento, la estabilidad, la compatibilidad web y cuenta con simplificaciones de código y sostenibilidad. Incluye varias características nuevas y mejoradas, incluyendo resultados de búsqueda más rápidos y una barra de herramientas de filtro rápido. Cuenta también con un nuevo asistente de migración y un nuevo administrador de archivos guardados.

Lo podes descargar desde este enlace y realizar una instalación manual, descomprimiendo su contenido en nuestra Home y creando un lanzador al bin de Thunderbrid.

Respecto de Ubuntu, se me ocurre que debiera ser subido a los repositorios oficiales de esta distribución; pero podes instalarlo tranquilamente haciendo uso de ubuntuzilla.

Instalación en Ubuntu y distribuciones que hacen uso de paquetería .deb.

  • Descargar Ubuntuzilla
  • Correr este comando desde la terminal: ubuntuzilla.py -a install -p thunderbird

Fuente

Disponibles los útimos drivers nVidia 256.35 vía PPA

nVidia ha publicado la última versión de sus drivers, se trata de la edición 256.35, y los tenemos disponibles para Ubuntu y derivados desde el repositorio PPA,  siendo estos sus principales cambios:

  • Added unofficial GLX protocol support
  • Improved Thermal Settings reporting in nvidia-settings to accurately reflect hardware configurations with multiple thermal sensors.
  • Fixed an interaction problem between Compiz and ‘screen-scraping’ VNC servers like x11vnc and vino that caused the screen to stop updating.
  • Enhanced VDPAU to add basic support for Xinerama. VDPAU will now operate on a single physical X screen under Xinerama. See the README for more details.
  • Enhanced VDPAU’s handling of corrupt clips of all formats on GPUs with VDPAU feature set C to be at least as good as on GPUs with VDPAU feature set B. This significantly improves various clips provided by nvnews.net user eamiller.
  • Fixed a bug in Xv attribute handling that caused hue, saturation,brightness, and contrast values to be misapplied when using an Xv overlay adaptor.
  • Implemented new APIs to allow sharing VDPAU surfaces with OpenGL andCUDA.
  • Removed precompiled kernel interfaces from the NVIDIA Linux-x86 .run file;

Notas del lanzamiento.

Antes de actualizarte, debes tener presente que estos drivers funcionan, en teoría, para Gforce Serie 6 y superior. En mi caso, una modesta Gforce 6600 de 256 mb. no se lleva nada bien con los drivers 195, sea Ubuntu o Windows 7 Ultimate. Por alguna razón que desconozco la cosa no corre fluída, sin embargo, con estos drivers la cosa cambió. Al menos por el momento, seguiré probando.

Para comentar en Web Upd8, experimenté ciertos problemas, quizás por consecuencia del sistema de comentarios de dicha web + flash player o no se, pero al comentar, ya se solucionó todo.

Instalación.

  • Repositorios para Lucid y Maverick:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade

  • Repositorios para Karmic Jaunty, Intrepid, Hardy:

sudo sh -c "echo 'deb http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu UBUNTU_VERSION main' >> /etc/apt/sources.list"
sudo sh -c "echo 'deb-src http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu UBUNTU_VERSION main' >> /etc/apt/sources.list"
sudo apt-get update
&& sudo apt-get install nvidia-glx-256 nvidia-256-modaliases nvidia-settings

Reemplazar UBUNTU_VERSION de acuerdo a nuestra versión de Ubuntu.

Posteriormente, debemos chequear que tenemos los últimos drivers activos, esto lo hacemos desde Sistema > Administración > Controladores de Hardware y reiniciamos.

Para volver atrás podemos hacer uso de PPA Purge.

Fuente

Nuevo Firefox 3.6.4 con plug-ins multiproceso: no more crashing!

La versión final de Firefox 3.6.4 ya está disponible para (casi)todo el mundo. Aunque el número de bugs y problemas de seguridad que se corrigen con este nuevo lanzamiento es muy amplio, una característica destaca por encima de todas las demás.

Hablamos de la protección que evitará que todo nuestro navegador se cierre por completo cuando existen problemas con algún plug-in. Por ahora, esta protección anti-crash será compatible con tan sólo tres tipos de tecnología (Flash, Quicktime y Silverlight), pero esto puede suponer el comienzo del fin de las incómodas y típicas ventanas grises que hasta ahora nos obligaban a reiniciar por completo nuestro navegador.

Nuestro compañero Miguel ya había comentado hace unos meses esta posibilidad, siempre y cuando las personas detrás de Firefox comenzaron a ayudarse del código libre de Chromium para conseguir que los plug-ins del navegador se ejecutasen en procesos independientes.

De aquí en adelante, cuando tengamos un problema de este tipo con alguno de los plug-ins mencionados, bastará con reiniciar la pestaña en concreto o abrir una nueva, puesto que el resto del navegador y sus diferentes pestañas seguirán funcionando de forma completamente normal.

Existe un pequeño “problema”, y es que por ahora esta nueva versión sólo estará disponible para Windows y Linux. Según explican desde Mozilla en su nota oficial, la adopción de estos cambios por parte de la versión Mac del navegador supondrían grandes cambios en su propia estructura, por lo que se esperará al lanzamiento de Firefox 4, que debería producirse antes de final de año.

Fuente

Instalar y configurar Spamassassin en servidores Centos y Red Hat

Introducción.

Acerca de SpamAssassin.

SpamAssassin es una implementación que utiliza un sistema de puntuación, basado sobre algoritmos de tipo genético, para identificar mensajes que pudieran ser sospechosos de ser correo masivo no solicitado, añadiendo cabeceras a los mensajes de modo que pueda ser filtrados por el cliente de correo electrónico o MUA (Mail User Agent).

URL: http://spamassassin.apache.org/

Acerca de Procmail.

Procmail es un programa que funciona como MDA (Mail Delivery Agent, o Agente de Entrega de Correo) que se utiliza para gestionar la entrega de correo local en el sistema. Ademñas de lo anterior, permite también realizar filtración automática del correo electrónico, pre-ordenamiento y otras tareas.

Procmail puede ser utilizad indistinta con Sendmail y Postfix.

URL: http://www.procmail.org

Leer más »

VLC 1.1.0 final liberado. Repositorio para Ubuntu 10.04 y 10.10

Finalmente VLC 1.1.0 «The Luggage» ha sido liberado. Este gran reproductor multimedia multiplataforma alcanza la estabilidad suficiente y ya contamos con esta nueva versión estable.

Muchos de nosotros lo venimos utilizando gracias a los repositorios de Web Upd8, pero esta versión final no nos llegará mediante dicho repo, sino que deberemos agregar otro repositorio.

De momento esta versión se encuentra disponible mediante Git y se especula que en las próximas horas sea subido a los distintos repositorios y ha su web oficial.

Novedades.

  • GPU and DSP decoding on selected platforms
  • New support for codecs, demuxers and muxers
  • Lua extensions and Lua content extensions (luaSD)
  • Improved interfaces
  • Video Output rework
  • Removal of lots of modules, rewrite of many
  • Improved performances, in CPU, RAM and I/O
  • New libVLC and bindings
  • New or improved ports on misc platforms
  • And many other features and bugs fixes

Para su instalación, deberemos esperar a que esté disponible desde su web oficial donde nos darán los instructivos para las distintas distribuciones. Los usuarios de Ubuntu Lucid o Maverick podemos usar la RC4 disponible en estos repositorios que se esperan en breve sean actualizados con esta nueva versión:

sudo add-apt-repository ppa:c-korn/vlc && sudo apt-get update
sudo apt-get install vlc mozilla-plugin-vlc

Como nota adicional, desde Web Upd8 nos informan que esta versión final ha sido compilada sin el soporte vaapi.

Fuente

Translate »