Utilizar un módem HSDPA USB Huawei E1556 en GNU/Linux Ubuntu 10.04

La situación.

El módem venía funcionando correctamente con la versión 9.10 de Ubuntu, sin embargo después de la instalación de la nueva versión (10.04) algo parece haber cambiado y el dispositivo sólo es identificado como un medio de almacenamiento (el controlador para Windows).

El problema.

Según el bug #521578 registrado en el LaunchPad de Ubuntu, el problema parece haber surgido debido a un movimiento de funcionalidades entre los paquetes udev (modem-modeswitch) y usb-modeswitch los cuales son responsables de garantizar que estos dispositivos USB no sean descubiertos únicamente como medios de almacenamiento con los drivers de Windows sino que sean identificados también como módems de banda ancha.  El paquete usb-modeswitch ahora con esta funcionalidad, no se instala por defecto en Ubuntu Lucid Lynx (10.04).

Este problema afecta a varios tipos de módems de la marca Huawei.

La solución.

La solución radica en instalar los paquetes requeridos.

$ sudo aptitude update && sudo aptitude install usb-modeswitch usb-modeswitch-data

Desconectar el módem USB y volver a conectarlo.  Este deberá ser reconocido normalmente a partir de ese momento.

Enlaces.

Fuente

Dejar un comentario?

1 Comentarios.

  1. Les cuento que yo tengo el Ubuntu 9.04 Desktop y lo instalé en una maquina vieja (P3 de 256 de RAM). Todo funcionó perfectamente, tomó bien el video, el audio, la tarjeta de red, pero no pude hacer funcionar el modem. Agregué la nueva conexion de “banda ancha” (jajaja) movil con el operador Comcel y descargué e instalé con mucha facilidad el paquete usb-modeswitch.deb

    Respecto a usb-modeswitch-data conseguí un archivo comprimido y seguí las instrucciones de instalación (make install). Supuestamente funcionó todo bien pero al momento de conectar el aparato nuevamente no se como indicarle que intente la conexión. Aclaro que estoy en una zona rural y solo me puedo conectar a través de mi portatil con win7 y el modem E1556 de Comcel. Con qué otra distribución podría probar el equipo viejo para dar mejor soporte al modem? Tengo en el fedora 10, el slackware 12.2, el mandrake 9.2 y 10.0, el mandriva 2005 y el mandriva free 2009. Cual de estos podria funcionar con 256 de RAM haciendo más simple el montaje del modem.

    Espero muy pronto cualquier ayuda pues según como me vaya quisiera asumir el reto de instalar el linux en mi portatil Dell.

Deje un comentario


NOTA - Puede usar estosHTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Translate »